Project

General

Profile

Bug #740

admin settings not available using my admin account

Added by Pierre-Louis Bonicoli 29 days ago. Updated 29 days ago.

Status:
Resolved
Priority:
Normal
Category:
Service :: Web
Start date:
2021-11-02
Due date:
% Done:

100%

Estimated time:
0:15 h
Patch Available:
Confirmed:
Yes
Branch:
Entity:
DuckCorp
Security:
No
Help Needed:
No

Description

Using my admin account (`pierre-louis`), i am not able to get the admin settings page, it returns an HTTP 403 error:

Accès non autorisé
L'utilisateur connecté doit être administrateur ou sous-administrateur

History

#1

Updated by Pierre-Louis Bonicoli 29 days ago

There are two pierre-louis accounts, one (who belongs to admin group) stored within the database, another (who belongs to mp-admins/dc-admins) within the LDAP.

I suggest to remove both accounts using occ command and to authenticate again using the LDAP credentials. This action should create a new pierre-louis account, isn'it?

#2

Updated by Pierre-Louis Bonicoli 29 days ago

  • Subject changed from admin settings not available using my admin admin to admin settings not available using my admin account
#3

Updated by Pierre-Louis Bonicoli 29 days ago

  • Category set to Service :: Web
#4

Updated by Pierre-Louis Bonicoli 29 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Estimated time set to 0:15 h
  • Confirmed changed from No to Yes
  • Security set to No
  • Help Needed set to No

Fixed with:

$ ssh root@toushirou
# su - php_stuff.milkypond.org -s /bin/bash
$ php occ user:delete pierre-louis_9030
The specified user could not be deleted. Please check the logs.
$ php occ user:delete pierre-louis
The specified user was deleted
$ php occ group:adduser admin pierre-louis_9030

Also available in: Atom PDF