Project

General

Profile

Bug #766

Orfeo postman[1643199]: /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require': cannot load such file -- active_ldap (LoadError)

Added by Pierre-Louis Bonicoli 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Service :: Mail
Start date:
2022-03-27
Due date:
% Done:

100%

Estimated time:
Patch Available:
Confirmed:
Yes
Branch:
Entity:
DuckCorp
Security:
No
Help Needed:

Description

Mar 27 23:29:04 Orfeo postman[1643199]: /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require': cannot load such file -- active_ldap (LoadError)
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /opt/cyborghood/lib/cyborghood/objects/ldap.rb:24:in `<top (required)>'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /opt/cyborghood/lib/cyborghood/objects.rb:20:in `<top (required)>'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /opt/cyborghood/lib/cyborghood/mail.rb:22:in `<top (required)>'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:85:in `require'
Mar 27 23:29:04 Orfeo postman[1643199]:         from /opt/cyborghood/bin/postman:30:in `<main>'
Mar 27 23:29:04 Orfeo systemd[1]: cyborghood_postman.service: Main process exited, code=exited, status=1/FAILURE

History

#1

Updated by Pierre-Louis Bonicoli 6 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • Security set to No

I installed the ruby-activeldap package and restarted cyborghood_postman.service.

cyborghood stuff doesn't belong to a Debian package: I guess the required dependencies such as ruby-activeldap must be installed manually.

The error message hasn't been logged since this restart.

Also available in: Atom PDF