Project

General

Profile

« Previous | Next » 

Revision 65c73cde

Added by Pierre-Louis Bonicoli about 12 years ago

  • ID 65c73cdedaac30cbc6e4b11cd6271b1541937cc6

Use gettext_rails/tools instead of gettext/utils

View differences:

config/initializers/app_deps.rb
1
require 'gettext_rails'
1

  
2 2
require 'exif'
3 3
require 'utils'
4 4
require 'mycyma'
5 5
require 'redcloth'
6

  
7
require "locale"
8
require "locale_rails"
9
require "gettext"
10
require "gettext_activerecord"
11
require "gettext_rails"
12

  
lib/tasks/gettext.rake
1 1

  
2 2
require 'mycyma'
3 3

  
4

  
5 4
namespace :i18n do
6
desc "Create mo-files for l10n"
5
  desc "Create mo-files for l10n"
7 6
  task :makemo do
8
    require 'gettext/utils'
9
    GetText.create_mofiles(true, "po", "locale")
7
    require 'gettext_rails/tools'
8
    GetText.create_mofiles
10 9
  end
11 10

  
12 11
  desc "Update pot/po files to match new version."
13 12
  task :updatepo do
14
    require 'gettext/utils'
13
    require 'gettext_rails/tools'
15 14
    GetText.update_pofiles(MyCyma::Info::app_name,
16 15
      Dir.glob("{app,lib}/**/*.{rb,rhtml}"),
17 16
      MyCyma::Info::versioned_name)

Also available in: Unified diff