Project

General

Profile

« Previous | Next » 

Revision d86eb8c1

Added by Marc Dequènes about 11 years ago

  • ID d86eb8c1b8f6de3ee06ecf232f233b4f3e9d3af1

[evol] partial upgrade to rails 2.2.2 (config+js) (full upgrade cancelled due to incompatibility with current gettext)

View differences:

config/boot.rb
67 67

  
68 68
    class << self
69 69
      def rubygems_version
70
        Gem::RubyGemsVersion if defined? Gem::RubyGemsVersion
70
        Gem::RubyGemsVersion rescue nil
71 71
      end
72 72

  
73 73
      def gem_version
......
82 82

  
83 83
      def load_rubygems
84 84
        require 'rubygems'
85

  
86
        unless rubygems_version >= '0.9.4'
87
          $stderr.puts %(Rails requires RubyGems >= 0.9.4 (you have #{rubygems_version}). Please `gem update --system` and try again.)
85
        min_version = '1.3.1'
86
        unless rubygems_version >= min_version
87
          $stderr.puts %Q(Rails requires RubyGems >= #{min_version} (you have #{rubygems_version}). Please `gem update --system` and try again.)
88 88
          exit 1
89 89
        end
90 90

  
91 91
      rescue LoadError
92
        $stderr.puts %(Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: http://rubygems.rubyforge.org)
92
        $stderr.puts %Q(Rails requires RubyGems >= #{min_version}. Please install RubyGems and try again: http://rubygems.rubyforge.org)
93 93
        exit 1
94 94
      end
95 95

  

Also available in: Unified diff