Project

General

Profile

Enhancement #750 » 0001-Update-build-configuration.patch

Loïc Gomez, 2022-01-10 20:48

View differences:

configure.ac
1
m4_pattern_allow([^AM_])
2
m4_pattern_allow([^AC_])
3

  
1 4
AC_PREREQ([2.69])
2 5
AC_INIT([Bip IRC Proxy],[0.9.2-git],[http://bip.milkypond.org/projects/bip/activity],[bip],[http://bip.milkypond.org/])
3 6
AM_INIT_AUTOMAKE([foreign subdir-objects -Wall -Werror])
......
12 15
AC_PROG_INSTALL
13 16
AM_PROG_LEX
14 17
AC_PROG_YACC
15
m4_ifndef([PKG_PROG_PKG_CONFIG], [m4_fatal([Please install pkg-config.])])
16
PKG_PROG_PKG_CONFIG
18

  
19
dnl PKG_PREREQ(MIN-VERSION)
20
dnl -----------------------
21
dnl Since: 0.29
22
dnl
23
dnl Verify that the version of the pkg-config macros are at least
24
dnl MIN-VERSION. Unlike PKG_PROG_PKG_CONFIG, which checks the user's
25
dnl installed version of pkg-config, this checks the developer's version
26
dnl of pkg.m4 when generating configure.
27
dnl
28
dnl To ensure that this macro is defined, also add:
29
dnl m4_ifndef([PKG_PREREQ],
30
dnl     [m4_fatal([must install pkg-config 0.29 or later before running autoconf/autogen])])
31
dnl
32
dnl See the "Since" comment for each macro you use to see what version
33
dnl of the macros you require.
34
m4_defun([PKG_PREREQ],
35
[m4_define([PKG_MACROS_VERSION], [0.29.1])
36
m4_if(m4_version_compare(PKG_MACROS_VERSION, [$1]), -1,
37
	[m4_fatal([pkg.m4 version $1 or higher is required but ]PKG_MACROS_VERSION[ found])])
38
])dnl PKG_PREREQ
39

  
40
dnl PKG_PROG_PKG_CONFIG([MIN-VERSION])
41
dnl ----------------------------------
42
dnl Since: 0.16
43
dnl
44
dnl Search for the pkg-config tool and set the PKG_CONFIG variable to
45
dnl first found in the path. Checks that the version of pkg-config found
46
dnl is at least MIN-VERSION. If MIN-VERSION is not specified, 0.9.0 is
47
dnl used since that's the first version where most current features of
48
dnl pkg-config existed.
49
AC_DEFUN([PKG_PROG_PKG_CONFIG],
50
[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
51
m4_pattern_allow([^PKG_CONFIG(_(PATH|LIBDIR|SYSROOT_DIR|ALLOW_SYSTEM_(CFLAGS|LIBS)))?$])
52
m4_pattern_allow([^PKG_CONFIG_(DISABLE_UNINSTALLED|TOP_BUILD_DIR|DEBUG_SPEW)$])
53
AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])
54
AC_ARG_VAR([PKG_CONFIG_PATH], [directories to add to pkg-config's search path])
55
AC_ARG_VAR([PKG_CONFIG_LIBDIR], [path overriding pkg-config's built-in search path])
56

  
57
if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
58
	AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
59
fi
60
if test -n "$PKG_CONFIG"; then
61
	_pkg_min_version=m4_default([$1], [0.9.0])
62
	AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
63
	if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
64
		AC_MSG_RESULT([yes])
65
	else
66
		AC_MSG_RESULT([no])
67
		PKG_CONFIG=""
68
	fi
69
fi[]dnl
70
])dnl PKG_PROG_PKG_CONFIG
17 71

  
18 72
PKG_CHECK_MODULES(OPENSSL, [libssl >= 0.9.8 libcrypto >= 0.9.8], [
19 73
			    with_openssl=yes
......
44 98
AM_CONDITIONAL([COND_WANT_TESTS], [test "$enable_tests" = yes])
45 99

  
46 100
AC_CHECK_FUNC(backtrace_symbols_fd, [
47
        AC_DEFINE(HAVE_BACKTRACE, [], [Use glibc backtrace on fatal()])
48
        LDFLAGS="-rdynamic $LDFLAGS"
49
        backtrace="(with backtrace)"
101
	    AC_DEFINE(HAVE_BACKTRACE, [], [Use glibc backtrace on fatal()])
102
	    LDFLAGS="-rdynamic $LDFLAGS"
103
	    backtrace="(with backtrace)"
50 104
])
51 105

  
52 106

  
53
- 
(23-23/24)