Project

General

Profile

Review #705

ansible-role-httpd_php_fpm: create Unix group used for pool workers

Added by Pierre-Louis Bonicoli 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Category:
-
Start date:
2020-07-01
Branch:
ansible-role-httpd_php_fpm@create_unix_group_for_pool_workers

Description

Repository/branch: ansible-role-httpd_php_fpm/create_unix_group_for_pool_workers

Create Unix group used for pool workers.

Fix this error:

TASK [zabbix : Generate Zabbix UI configuration]
task path: duckcorp-infra/ansible/roles/zabbix/tasks/webui.yml:30
fatal: [Orthos]: FAILED! => {
    "changed": false,
    "owner": "root",
    "group": "root",
    "mode": "0644",
    "msg": "chgrp failed: failed to look up group php_sup.duckcorp.org",
    "path": "/etc/zabbix/zabbix.conf.php",
    "state": "file",
}

Related issues

Blocks DuckCorp Infrastructure - Review #704: duckcorp-infra: move supervision serverResolved2020-07-01Actions

History

#1

Updated by Pierre-Louis Bonicoli 5 months ago

  • Copied from Review #702: ansible-role-httpd_php_fpm: improve check mode support added
#2

Updated by Pierre-Louis Bonicoli 5 months ago

  • Copied from deleted (Review #702: ansible-role-httpd_php_fpm: improve check mode support)
#3

Updated by Pierre-Louis Bonicoli 5 months ago

  • Blocks Review #704: duckcorp-infra: move supervision server added
#4

Updated by Pierre-Louis Bonicoli 5 months ago

  • Copied to Review #706: ansible-role-httpd_php_fpm: dont_check_potentially_non_existent_path added
#5

Updated by Pierre-Louis Bonicoli 5 months ago

  • Copied to deleted (Review #706: ansible-role-httpd_php_fpm: dont_check_potentially_non_existent_path)
#6

Updated by Marc Dequènes 5 months ago

  • Assignee changed from Marc Dequènes to Pierre-Louis Bonicoli

It should have created a group of the same name. I checked an USERGROUPS_ENAB is set to yes on Orthos, so there is a problem somewhere.

I would prefer we find out the source of the problem before deciding on a fix. I'm not opposed to creating the group separately but the current patch does not reproduce the intended behavior since it adds the user in the users group which is not something we want. So if we choose to use this patch then we would need to make the new group the primary group. Then we need to fix the current installation on Orthos.

#7

Updated by Pierre-Louis Bonicoli 5 months ago

  • Status changed from In Progress to Rejected
  • Branch changed from ansible-role-httpd_php_fpm@ create_unix_group_for_pool_workers to ansible-role-httpd_php_fpm@create_unix_group_for_pool_workers

It looks like I tried to move the Generate Zabbix UI configuration before the Install PHP for the vhost (in order to workaround #706). Since this update has been discarded, this issue can be discarded too :)

Also available in: Atom PDF