Project

General

Profile

Enhancement #716

Preparing Bullseye

Added by Marc Dequènes 6 months ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
DC Admins
Category:
-
Start date:
2021-01-20
Due date:
% Done:

0%

Estimated time:
Patch Available:
Confirmed:
No
Branch:
Entity:
DuckCorp
Security:
Help Needed:

Description

Quack,

Here is a todolist of all the things we need to care to help upgrading to the new Debian release when it's out.

Software that would need upgrading:
  • Inspircd v3 (backported in our repo and config adapted/improved)
  • Mailman 3 (need backport)
  • Bind9 9.16 (backport available) with DNSSEC key management changes which need procedures and Ansible adaptation

Software that need to be replaced and why (unmaintained, problematic…):

Software that we could consider for deprecation:

Other things to consider:
  • Redmine is still not catching up with Rails 6 and will not be in Bullseye, maybe backport but expected much later

History

#1

Updated by Marc Dequènes 5 months ago

  • Description updated (diff)
#2

Updated by Marc Dequènes 3 months ago

  • Description updated (diff)

Also available in: Atom PDF