Project

General

Profile

Enhancement #6

Per user language

Added by Pierre-Louis Bonicoli almost 11 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Low
Category:
Admin UI
Start date:
2009-01-04
Due date:
% Done:

100%

Estimated time:
Patch Available:
No
Confirmed:
No
Help Needed:

Description

Logged user can not choose language of the interface (option not available when editing property of a user).


Un utilisateur connecté ne peut pas sélectionner la langue de l'interface.

Associated revisions

Revision 73f2fc18 (diff)
Added by Marc Dequènes over 10 years ago

[evol] language can be forced in the user admin page (closes #6) (no user interface yet)

History

#1

Updated by Marc Dequènes over 10 years ago

MyCyma just uses the langage advertised by the browser (see browser preferences). This is good because a langage is choosen properly before even being loggued (or if you're just a mere visitor). I don't see any reason to override this setting. Would you please give a proper rational of situations where it would be better handled this way ?

We might add such a preference setting in MyCyma, but then i would suggest to have an "auto" mode selected by default, working with the browser preference.

#2

Updated by Marc Dequènes over 10 years ago

  • Status changed from New to Feedback
#3

Updated by Pierre-Louis Bonicoli over 10 years ago

Even google allow users to choose language of the interface ;)
Moreover user could be connected from a cybercafé.

#4

Updated by Marc Dequènes over 10 years ago

  • Category set to Admin UI
  • Status changed from Feedback to In Progress
  • Priority changed from Normal to Low

Should allow forcing the user langage.

Please not a user cannot yet change its preferences by himself yet (but this is another issue).

#5

Updated by Marc Dequènes over 10 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF